AgMD2 Driver LabVIEW Help

You are here: AgMD2 Driver LabVIEW Help

Agilent Technologies

AgMD2 High-Speed Digitizer Driver

LabVIEW Help and Programming Information

Introduction

This help document is intended to provide in-depth information and reference material for the Agilent MD2 LabVIEW Driver.

Contents:

Programming Guide

Programming Reference

© Agilent Technologies, Inc. 2013. | Help version: 13 January 2014
Part No: M9700-90004 |


Programming Reference

You are here: AgMD2 LabVIEW Driver Help > Programming Reference

Programming Guide

This section provides information and examples for using the MD2 LabVIEW G Driver.

Scenarios and Sample Programs

Example: Simple Acquisition

Example: Multi Record Acquisition


Scenarios and Sample Programs

The following example programs are provided to demonstrate certain features in a typical AgMD2 supported Digitizer.

Each example VI has a front panel you can use to exercise the underlying VI functions.

Example: Simple Acquisition

Example: Multi Record Acquisition


AgMD2 : Simple Acquisition

This example initializes the instrument, reads a few Identity interface properties, and performs a simple acquisition.


AgMD2 : Multi Record Acquisition

This example initializes the instrument, reads a few Identity interface properties, and performs a multi record acquisition.


Programming Reference

This section provides information on each of the VIs and the associated Attributes in the MD2 LabVIEW G Driver.

AgMD2 Methods (VIs)

VI Tree

Initialize

Initialize With Options

Close

Action-Status

Configure

Data

Utility

AgMD2 Attributes

ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED

ACQUISITION_MODE

ACTIVE_TRIGGER_SOURCE

BOARD_TEMPERATURE

CALIBRATION_IS_REQUIRED

CHANNEL_CONNECTOR_NAME

CHANNEL_COUNT

CHANNEL_ENABLED

CHANNEL_TEMPERATURE

CONTROL_IO_AVAILABLE_SIGNALS

CONTROL_IO_COUNT

CONTROL_IO_SIGNAL

DELAY_CONTROL_COUNT

DELAY_CONTROL_ENABLE

DELAY_CONTROL_MAX

DELAY_CONTROL_MIN

DELAY_CONTROL_RANGE

DELAY_CONTROL_VALUE

DRIVER_SETUP

INPUT_CONNECTOR_SELECTION

INPUT_FILTER_BYPASS

INPUT_FILTER_MAX_FREQUENCY

INPUT_FILTER_MIN_FREQUENCY

INPUT_IMPEDANCE

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_INFO_CHASSIS_NUMBER

INSTRUMENT_INFO_IO_VERSION

INSTRUMENT_INFO_NBRADC_BITS

INSTRUMENT_INFO_OPTIONS

INSTRUMENT_INFO_SERIAL_NUMBER_STRING

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_RESOURCE_DESCRIPTOR

IS_IDLE

IS_MEASURING

IS_WAITING_FOR_ARM

IS_WAITING_FOR_TRIGGER

LOGIC_DEVICE_COUNT

LOGIC_DEVICE_FIRMWARE_STORE_COUNT

LOGIC_DEVICE_IFDL_COUNT

LOGIC_DEVICE_IFDL_ENABLED

LOGIC_DEVICE_IFDL_IS_ACTIVE

LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL

LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE

LOGIC_DEVICE_MEMORY_BANK_COUNT

LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED

LOGIC_DEVICE_SAMPLES_UNSIGNED

LOGIC_DEVICE_STREAM_MODE

LOGIC_DEVICE_STREAMS_COUNT

LOGICAL_NAME

MAX_FIRST_VALID_POINT_VAL

MAX_SAMPLES_PER_CHANNEL

MIN_RECORD_SIZE

MODULE_SYNCHRONIZATION_HANDLE

MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE

MONITORING_VALUE_COUNT

MONITORING_VALUE_CURRENT_VALUE

MONITORING_VALUE_LIMIT_HIGH

MONITORING_VALUE_LIMIT_LOW

MONITORING_VALUE_UNIT

NUM_ACQUIRED_RECORDS

NUM_RECORDS_TO_ACQUIRE

RECORD_SIZE

REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

REFERENCE_OSCILLATOR_OUTPUT_ENABLED

REFERENCE_OSCILLATOR_SOURCE

SAMPLE_CLOCK_EXTERNAL_DIVIDER

SAMPLE_CLOCK_EXTERNAL_FREQUENCY

SAMPLE_CLOCK_OUTPUT_ENABLED

SAMPLE_CLOCK_SOURCE

SAMPLE_RATE

SIMULATE

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

SUPPORTED_INSTRUMENT_MODELS

TEMPERATURE_UNITS

TIME_INTERLEAVED_CHANNEL_LIST

TIME_INTERLEAVED_CHANNEL_LIST_AUTO

TRIGGER_COUPLING

TRIGGER_DELAY

TRIGGER_HYSTERESIS

TRIGGER_LEVEL

TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES

TRIGGER_MAGNITUDE_SLOPE

TRIGGER_OUTPUT_ENABLED

TRIGGER_OUTPUT_OFFSET

TRIGGER_OUTPUT_SOURCE

TRIGGER_SLOPE

TRIGGER_SOURCE_COUNT

TRIGGER_SOURCE_OPERATOR

TRIGGER_TYPE

USER_CONTROL_COUNTERS_MODE

USER_CONTROL_INTER_SEGMENT_DELAY_MODE

USER_CONTROL_INTER_SEGMENT_DELAY_VALUE

USER_CONTROL_POST_TRIGGER

USER_CONTROL_PRE_TRIGGER

USER_CONTROL_START_ON_TRIGGER_ENABLED

USER_CONTROL_TRIGGER_ENABLE_SOURCE

USER_CONTROL_TRIGGER_FACTOR

USER_CONTROL_TRIGGER_SELECTION

VERTICAL_COUPLING

VERTICAL_OFFSET

VERTICAL_RANGE


AgMD1 Methods (VI's)

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD1 Methods (VI's)

Agilent AgMD1 Methods (VIs)

This section provides technical and programming support for using the Agilent AgMD2 LabVIEW API VIs to develop applications for your Digitizers.

The VIs are split into the following main topics, depending on their function:

VI Tree

Initialize

Initialize With Options

Close

Action-Status

Acquisition

Status

Get Channel Name

Get ControlIO Name

Get Delay Control Name

Get Logic Device Name

Get Monitoring Value Name

Get Trigger Source Name

Logic Device Load From File

Send Software Trigger

Configure

Low Level

Reference Oscillator

Trigger

Configure Acquisition Record

Configure Channel

Configure Input Filter

Configure Temperature Units

Configure Time Interleaved Channel List

Module Synchronization Configure Slaves

Data

Fetch

Fetch Multi-Record

Read

Module Synchronization Get Slaves

Utility

Calibration

Instrument Info

Disable

Error Message

Error-Query

Query Board Temperature

Query Channel Temperature

Query Min Waveform Memory

Reset

Reset With Defaults

Revision Query

Self Calibrate

Self-Test


AgMD2 : VI Tree

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.


AgMD2 : Initialize

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Inputs

resource string

A string that specifies the instrument to connect to. This can either be a VISA resource name (also known as a VISA address) or an IVI session, or an IVI logical name. For PXI instruments, a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer can be found using the Agilent Connection Expert. To configure an IVI session or IVI logical name, consult the IVI tools on your system, such as NI-MAX(Agilent devices may not appear in NI Max).

id query (Off)

Specifies whether to verify the ID of the instrument.

reset device (Off)

Specifies whether to reset the instrument.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

Unique identifier for an IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Initialize With Options

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Inputs

resource string

A string that specifies the instrument to connect to. This can either be a VISA resource name (also known as a VISA address) or an IVI session, or an IVI logical name. For PXI instruments, a VISA resource name is of the form: PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer can be found using the Agilent Connection Expert. To configure an IVI session or IVI logical name, consult the IVI tools on your system, such as NI-MAX(Agilent devices may not appear in NI Max).

id query (Off)

Specifies whether to verify the ID of the instrument.

reset device (Off)

Specifies whether to reset the instrument.

option string

Use to specify the initial values of certain IVI inherent properties for the session. The format of an assignment in the OptionsString parameter is "Name=Value", where Name is one of

Name | Value
Simulate | True/False
DriverSetup | (see below)

If the Options String parameter contains an assignment for the Driver Setup property, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

Unique identifier for an IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Close

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Action Status VI's

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Action Status VI's

Action Status

Contained in this section are VIs which control the status or initiate actions within the instrument.

Acquisition

Abort

Initiate Acquisition

Apply Setup

Wait For Acquisition Complete

Status

Is Idle

Is Measuring

Is Waiting for Arm

Is Waiting For Trigger

Get Channel Name

Get ControlIO Name

Get Delay Control Name

Get Logic Device Name

Get Monitoring Value Name

Get Trigger Source Name

Logic Device Load From File

Send Software Trigger


Action Status \ Low Level VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Action Status \ Low Level VIs

Acquisition

Contained in this section are VIs which are used to access the low-level operations of the instrument.

Abort

Initiate Acquisition

Apply Setup

Wait For Acquisition Complete


AgMD2 : Abort

Aborts an acquisition and returns the digitizer to the Idle state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Initiate Acquisition

Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Apply Setup

Applies directly the configured properties setup to the instrument.

No configuration change is immediately applied to the instrument hardware. This means that setting any attribute only changes the 'setup' in the driver, and an explicit call to ApplySetup is required to have the change be effective in the instrument hardware.

There are some exceptions for actions: VIs that perform an action, which, for example, also modify the instrument's state. Currently, the following functions do perform an implicit ApplySetup before the actual action:

VI Name | Description
Self Test | To ensure the instrument is actually in the desired state before doing the self test.
Self Calibrate | To ensure the instrument is actually in the desired state before self-calibrating.
Initiate Acquisition | To apply the configured setup to the instrument hardware before starting the measurement.
Read | All Read methods start by performing an Initiate followed by Wait and then Fetch.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Wait For Acquisition Complete

Waits until the configured acquisition is complete. If no acquisition is currently running, this VI returns immediately. If the acquisition does not complete within the time period the user specified with the Maximum Time parameter, the VI returns the Max Time Exceeded error.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Maximum Time

Specifies the maximum time the end-user allows for this VI to complete. The units are milliseconds. Use '0' for immediate (no wait), and '-1' to wait indefinitely.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Action Status \ Low Level VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Action Status \ Low Level VIs

Status

Contained in this section are VIs which determine the state of the digitizer.

Is Idle

Is Measuring

Is Waiting for Arm

Is Waiting For Trigger


AgMD2 : Is Idle

Determines if the digitizer is currently in the Idle state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Idle state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned Value | Meaning
AcquisitionStatusResultTrue | The digitizer is currently in the Idle state
AcquisitionStatusResultFalse | The digitizer is not currently in the Idle state
AcquisitionStatusResultUnknown | The driver cannot query the instrument to determine the digitizer state

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Is Measuring

Determines if the digitizer is currently in the Measuring state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Measuring state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned Value | Meaning
AcquisitionStatusResultTrue | The digitizer is currently in the Measuring state
AcquisitionStatusResultFalse | The digitizer is not currently in the Measuring state
AcquisitionStatusResultUnknown | The driver cannot query the instrument to determine the digitizer state

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Is Waiting For Arm

Determines if the digitizer is currently in the Waiting For Arm state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the WaitingForArm state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned Value | Meaning
AcquisitionStatusResultTrue | The digitizer is currently waiting for Arm
AcquisitionStatusResultFalse | The digitizer is not currently waiting for Arm
AcquisitionStatusResultUnknown | The driver cannot query the instrument to determine the digitizer state

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Is Waiting For Trigger

Determines if the digitizer is currently in the Waiting For Trigger state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Waiting For Trigger state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned Value | Meaning
AcquisitionStatusResultTrue | The digitizer is currently waiting for Trigger
AcquisitionStatusResultFalse | The digitizer is not currently waiting for Trigger
AcquisitionStatusResultUnknown | The driver cannot query the instrument to determine the digitizer state

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Channel Name

Returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Channel Count, the VI returns an empty string in the Name parameter and returns an error.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Index

A one-based index that defines which name to return.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Channel Name

A string containing the channel name.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Control IO Name

Returns the Control IO Connector name that corresponds to the one-based index that the user specifies.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Delay Control Name

Returns the delay control name that corresponds to the one-based index that the user specifies.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass an empty string for this parameter if the buffer size parameter is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Logic Device Name

Returns the logic device name that corresponds to the one-based index that the user specifies.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass an empty string for this parameter if the buffer size parameter is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Monitoring Value Name

Returns the Monitoring Value name that corresponds to the one-based index that the user specifies.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass an empty string for this parameter if the buffer size parameter is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Trigger Source Name

Returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Trigger Source Count, the VI returns an empty string in the Name parameter and returns an error.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Source Index

A one-based index that defines which name to return.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Source Name

Specifies a buffer into which the driver stores the channel name.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Logic Device Load From File

Loads the bitfile to the logic device.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

LogicDevice

The physical or virtual repeated capability identifier. Pass an empty string if the operation does not apply to a repeated capability. You can also pass an empty string if the device only has a single Logic Device.

Path

Specifies the path of the bitfile location.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Send Software Trigger

Sends a software generated trigger to the instrument. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Configuration VIs

Contained in this section are VIs which are used to configure the instrument.

Low Level

Get Attribute ViBoolean

Get Attribute ViInt32

Get Attribute ViInt64

Get Attribute ViReal64

Get Attribute ViString

Set Attribute ViBoolean

Set Attribute ViInt32

Set Attribute ViInt64

Set Attribute ViReal64

Set Attribute ViString

Reference Oscillator

Configure Reference Oscillator Output Enabled

Configure Reference Oscillator

Trigger

Configure Edge Trigger Source

Configure Pretrigger Samples

Configure Trigger Holdoff

Trigger Magnitude Configure

Configure Acquisition Record

Configure Channel

Configure Input Filter

Configure Temperature Units

Configure Time Interleaved Channel List

Module Synchronization Configure Slaves


Configuration \ Low Level VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Configuration \ Low Level VIs

Configuration \ Low-level VIs

Contained in this section are VIs which are used to access the low-level operations of the instrument.

Get Attribute ViBoolean

Get Attribute ViInt32

Get Attribute ViInt64

Get Attribute ViReal64

Get Attribute ViString

Set Attribute ViBoolean

Set Attribute ViInt32

Set Attribute ViInt64

Set Attribute ViReal64

Set Attribute ViString


AgMD2 : Get Attribute ViBoolean

Gets a Boolean attribute from the instrument driver. The following attributes are supported:

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED
  • CALIBRATION_IS_REQUIRED
  • CHANNEL_ENABLED
  • DELAY_CONTROL_ENABLED
  • INPUT_FILTER_BYPASS
  • LOGIC_DEVICE_IFDL_ENABLED
  • LOGIC_DEVICE_IFDL_IS_ACTIVE
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED
  • LOGIC_DEVICE_SAMPLES_UNSIGNED
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED
  • SAMPLE_CLOCK_OUTPUT_ENABLED
  • SIMULATE
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO
  • TRIGGER_OUTPUT_ENABLED

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED: Enables or disables the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
  • CALIBRATION_IS_REQUIRED: Returns whether or not a self calibration is required.
  • CHANNEL_ENABLED: Specifies whether the digitizer acquires a waveform for the channel.
  • DELAY_CONTROL_ENABLED: Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
  • INPUT_FILTER_BYPASS: Specifies whether or not to bypass the input filter.
  • LOGIC_DEVICE_IFDL_ENABLED: Specifies whether the IFDL is enabled.
  • LOGIC_DEVICE_IFDL_IS_ACTIVE: Returns whether the IFDL is currently active.
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED: Enables the FIFO mode for MemoryBank. Used when streaming.
  • LOGIC_DEVICE_SAMPLES_UNSIGNED: When True, directs the LogicDevice to receive unsigned samples values from the ADC.
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED: Specifies whether or not the reference frequency signal appears at an output of the digitizer.
  • SAMPLE_CLOCK_OUTPUT_ENABLED: Specifies whether or not the sample clock appears at a reference output of the digitizer.
  • SIMULATE: If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO: Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.
  • TRIGGER_OUTPUT_ENABLED: Specifies whether or not an accepted trigger appears at an output of the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViInt32

Gets an Int32 attribute from the instrument driver. The following attributes are supported:

  • ACQUISITION_MODE
  • CHANNEL_COUNT
  • CONTROL_IO_COUNT
  • DELAY_CONTROL_COUNT
  • DELAY_CONTROL_MAX
  • DELAY_CONTROL_MIN
  • DELAY_CONTROL_RANGE
  • DELAY_CONTROL_VALUE
  • INPUT_CONNECTOR_SELECTION
  • INSTRUMENT_INFO_CHASSIS_NUMBER
  • INSTRUMENT_INFO_NBR_ADC_BITS
  • IS_IDLE
  • IS_MEASURING
  • IS_WAITING_FOR_ARM
  • IS_WAITING_FOR_TRIGGER
  • LOGIC_DEVICE_COUNT
  • LOGIC_DEVICE_FIRMWARE_STORE_COUNT
  • LOGIC_DEVICE_IFDL_COUNT
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE
  • LOGIC_DEVICE_MEMORY_BANK_COUNT
  • LOGIC_DEVICE_STREAM_MODE
  • LOGIC_DEVICE_STREAMS_COUNT
  • MODULE_SYNCHRONIZATION_HANDLE
  • MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE
  • REFERENCE_OSCILLATOR_SOURCE
  • SAMPLE_CLOCK_SOURCE
  • TEMPERATURE_UNITS
  • TRIGGER_COUPLING
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES
  • TRIGGER_MAGNITUDE_SLOPE
  • TRIGGER_SLOPE
  • TRIGGER_SOURCE_COUNT
  • TRIGGER_SOURCE_OPERATOR
  • TRIGGER_TYPE
  • VERTICAL_COUPLING

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_MODE: The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A
  • CHANNEL_COUNT: Returns the number of Control IO Connectors.
  • CONTROL_IO_COUNT: Simulate=true, DriverSetup= Model=U5303A
  • DELAY_CONTROL_COUNT: Returns the number of delay controls.
  • DELAY_CONTROL_MAX: Maximum value (DAC code) that can be set for the delay control.
  • DELAY_CONTROL_MIN: Minimum value (DAC code) that can be set for the delay control.
  • DELAY_CONTROL_RANGE: Selects the range for the delay control. Useful only for delay controls with multiple ranges.
  • DELAY_CONTROL_VALUE: The value (DAC code) set for the delay control.
  • INPUT_CONNECTOR_SELECTION: Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.
  • INSTRUMENT_INFO_CHASSIS_NUMBER: Chassis number.
  • INSTRUMENT_INFO_NBR_ADC_BITS: Number of bits of data per sample from this module's ADCs.
  • IS_IDLE: Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
  • IS_MEASURING: Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
  • IS_WAITING_FOR_ARM: Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
  • IS_WAITING_FOR_TRIGGER: Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
  • LOGIC_DEVICE_COUNT: Returns the number of logic devices.
  • LOGIC_DEVICE_FIRMWARE_STORE_COUNT: Number of available firmware stores in the LogicDevice.
  • LOGIC_DEVICE_IFDL_COUNT: Returns the number of LogicDevice IFDLs.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL: Specifies how the MemoryBank accesses are controlled. This value is used only when the Acquisition Mode is UserFDK.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE: When MemoryBank access is controlled by software, specifies how the memory is currently accessed.
  • LOGIC_DEVICE_MEMORY_BANK_COUNT: Number of memory banks in LogicDevice.
  • LOGIC_DEVICE_STREAM_MODE: Specifies the mode the Streams are operating in.
  • LOGIC_DEVICE_STREAMS_COUNT: Number of Streams available in the LogicDevice.
  • MODULE_SYNCHRONIZATION_HANDLE: The handle of the current module.
  • MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE: The handle of the master module, when synchronized. This value will be identical to the attribute Handle if this module is the master, and equal to 0 when not synchronized.
  • REFERENCE_OSCILLATOR_SOURCE: Specifies the reference frequency source used.
  • SAMPLE_CLOCK_SOURCE: Specifies the clock used to pace acquisition sampling.
  • TEMPERATURE_UNITS: Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
  • TRIGGER_COUPLING: Specifies how the digitizer couples the trigger source.
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES: Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
  • TRIGGER_MAGNITUDE_SLOPE: Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.
  • TRIGGER_SLOPE: Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.
  • TRIGGER_SOURCE_COUNT: The number of trigger sources.
  • TRIGGER_SOURCE_OPERATOR: Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute.
  • TRIGGER_TYPE: The kind of event that triggers the digitizer.
  • VERTICAL_COUPLING: Specifies how the digitizer couples the input signal for the channel.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViInt64

Gets an Int64 attribute from the instrument driver. The following attributes are supported:

  • MAX_FIRST_VALID_POINT_VAL
  • MAX_SAMPLES_PER_CHANNEL
  • MIN_RECORD_SIZE
  • NUM_ACQUIRED_RECORDS
  • NUM_RECORDS_TO_ACQUIRE
  • RECORD_SIZE

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • MAX_FIRST_VALID_POINT_VAL: Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieve the entire acquisition.
  • MAX_SAMPLES_PER_CHANNEL: Returns the maximum number of samples per channel that can be captured.
  • MIN_RECORD_SIZE: Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, this attribute returns 1.
  • NUM_ACQUIRED_RECORDS: Gets the total number of records acquired since the acquisition was last initiated. You may call this method while an acquisition is in progress.
  • NUM_RECORDS_TO_ACQUIRE: Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
  • RECORD_SIZE: Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, this attribute returns 1.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViReal64

Gets a Real64 attribute from the instrument driver. The following attributes are supported:

  • BOARD_TEMPERATURE
  • CHANNEL_TEMPERATURE
  • INPUT_FILTER_MAX_FREQUENCY
  • INPUT_FILTER_MIN_FREQUENCY
  • INPUT_IMPEDANCE
  • MONITORING_VALUE_CURRENT_VALUE
  • MONITORING_VALUE_LIMIT_HIGH
  • MONITORING_VALUE_LIMIT_LOW
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY
  • SAMPLE_RATE
  • TRIGGER_DELAY
  • TRIGGER_HYSTERESIS
  • TRIGGER_LEVEL
  • TRIGGER_OUTPUT_OFFSET
  • VERTICAL_OFFSET
  • VERTICAL_RANGE

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • BOARD_TEMPERATURE: Indicates the temperature of the entire board. The units are governed by the Temperature Units attribute.
  • CHANNEL_TEMPERATURE: Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.
  • INPUT_FILTER_MAX_FREQUENCY: Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_FILTER_MIN_FREQUENCY: Specifies the minimum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_IMPEDANCE: The input impedance of this channel. The units are Ohms.
  • MONITORING_VALUE_CURRENT_VALUE: Returns the current monitored value of the MonitoringValue.
  • MONITORING_VALUE_LIMIT_HIGH: Returns the limit value above which the instrument behavior may not be consistent with the specifications.
  • MONITORING_VALUE_LIMIT_LOW: Returns the limit value below which the instrument behavior may not be consistent with the specifications.
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER: Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
  • SAMPLE_RATE: Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
  • TRIGGER_DELAY: Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
  • TRIGGER_HYSTERESIS: Specifies the trigger hysteresis in Volts.
  • TRIGGER_LEVEL: Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
  • TRIGGER_OUTPUT_OFFSET: Specifies the offset in Volts at the trigger output of the digitizer.
  • VERTICAL_OFFSET: The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
  • VERTICAL_RANGE: The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Get Attribute ViString

Gets a String attribute from the instrument driver. The following attributes are supported:

  • ACTIVE_TRIGGER_SOURCE
  • CHANNEL_CONNECTOR_NAME
  • CONTROL_IO_AVAILABLE_SIGNALS
  • CONTROL_IO_SIGNAL
  • DRIVER_SETUP
  • INSTRUMENT_FIRMWARE_REVISION
  • INSTRUMENT_INFO_IO_VERSION
  • INSTRUMENT_INFO_OPTIONS
  • INSTRUMENT_INFO_SERIAL_NUMBER_STRING
  • INSTRUMENT_MANUFACTURER
  • INSTRUMENT_MODEL
  • IO_RESOURCE_DESCRIPTOR
  • LOGICAL_NAME
  • MONITORING_VALUE_UNIT
  • SPECIFIC_DRIVER_DESCRIPTION
  • SPECIFIC_DRIVER_REVISION
  • SPECIFIC_DRIVER_VENDOR
  • SUPPORTED_INSTRUMENT_MODELS
  • TIME_INTERLEAVED_CHANNEL_LIST
  • TRIGGER_OUTPUT_SOURCE

Inputs

instrument handle

Returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACTIVE_TRIGGER_SOURCE: Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability.
  • CHANNEL_CONNECTOR_NAME: The connector name as it appears on the instrument's front panel.
  • CONTROL_IO_AVAILABLE_SIGNALS: Comma separated list of available signal names that can be used for the Signal attribute of this repeated capability.
  • CONTROL_IO_SIGNAL: Signal present on a Control IO connector.
  • DRIVER_SETUP: The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
  • INSTRUMENT_FIRMWARE_REVISION: The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
  • INSTRUMENT_INFO_IO_VERSION: Version of the IO Driver used by this module.
  • INSTRUMENT_INFO_OPTIONS: Comma separated list of options installed in this instrument.
  • INSTRUMENT_INFO_SERIAL_NUMBER_STRING: The serial number of the instrument.
  • INSTRUMENT_MANUFACTURER: The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
  • INSTRUMENT_MODEL: The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes.
  • IO_RESOURCE_DESCRIPTOR: The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
  • LOGICAL_NAME: Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
  • MONITORING_VALUE_UNIT: Returns the unit of this monitoring value.
  • SPECIFIC_DRIVER_DESCRIPTION: Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SPECIFIC_DRIVER_REVISION: Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SPECIFIC_DRIVER_VENDOR: Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
  • SUPPORTED_INSTRUMENT_MODELS: A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
  • TIME_INTERLEAVED_CHANNEL_LIST: This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one or more channel names.
  • TRIGGER_OUTPUT_SOURCE: Selects the trigger signal to drive the trigger output connector on the front panel.

AttributeValueBufferSize

The number of bytes in the string that the user specifies for the AttributeValue parameter.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

This control returns an Instrument Handle that is used in all subsequent VI calls to differentiate between different sessions of this instrument driver.

Note: Each time this VI is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Boolean

Sets a Boolean attribute from the instrument driver. The following attributes are supported:

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED
  • CHANNEL_ENABLED
  • DELAY_CONTROL_ENABLED
  • INPUT_FILTER_BYPASS
  • LOGIC_DEVICE_IFDL_ENABLED
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED
  • LOGIC_DEVICE_SAMPLES_UNSIGNED
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED
  • SAMPLE_CLOCK_OUTPUT_ENABLED
  • SIMULATE
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO
  • TRIGGER_OUTPUT_ENABLED

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED: Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
  • CHANNEL_ENABLED: Specifies whether the digitizer acquires a waveform for the channel.
  • DELAY_CONTROL_ENABLED: Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
  • INPUT_FILTER_BYPASS: Specifies whether or not to bypass the input filter.
  • LOGIC_DEVICE_IFDL_ENABLED: Specifies whether the IFDL is enabled.
  • LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED: Enables the FIFO mode for MemoryBank. Used when streaming.
  • LOGIC_DEVICE_SAMPLES_UNSIGNED: When True, directs the LogicDevice to receive unsigned samples values from the ADC.
  • REFERENCE_OSCILLATOR_OUTPUT_ENABLED: Specifies whether or not the reference frequency signal appears at an output of the digitizer.
  • SAMPLE_CLOCK_OUTPUT_ENABLED: Specifies whether or not the sample clock appears at a reference output of the digitizer.
  • SIMULATE: If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
  • TIME_INTERLEAVED_CHANNEL_LIST_AUTO: Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.
  • TRIGGER_OUTPUT_ENABLED: Specifies whether or not an accepted trigger appears at an output of the digitizer.

AttributeValue (Off)

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Int32

Sets an Int32 attribute from the instrument driver. The following attributes are supported:

  • ACQUISITION_MODE
  • DELAY_CONTROL_RANGE
  • DELAY_CONTROL_VALUE
  • INPUT_CONNECTOR_SELECTION
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE
  • LOGIC_DEVICE_STREAM_MODE
  • REFERENCE_OSCILLATOR_SOURCE
  • SAMPLE_CLOCK_SOURCE
  • TEMPERATURE_UNITS
  • TRIGGER_COUPLING
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES
  • TRIGGER_MAGNITUDE_SLOPE
  • TRIGGER_SLOPE
  • TRIGGER_SOURCE_OPERATOR
  • TRIGGER_TYPE
  • VERTICAL_COUPLING

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACQUISITION_MODE: The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A
  • DELAY_CONTROL_RANGE: Selects the range for the delay control. Useful only for delay controls with multiple ranges.
  • DELAY_CONTROL_VALUE: The value (DAC code) set for the delay control.
  • INPUT_CONNECTOR_SELECTION: Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL: Specifies how the MemoryBank accesses are controlled. This value is used only when the Acquisition Mode is UserFDK.
  • LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE: When MemoryBank access is controlled by software, this attribute specifies how the memory is currently accessed.
  • LOGIC_DEVICE_STREAM_MODE: Specifies the mode the Streams are operating in.
  • REFERENCE_OSCILLATOR_SOURCE: Specifies the reference frequency source used.
  • SAMPLE_CLOCK_SOURCE: Specifies the clock used to pace acquisition sampling.
  • TEMPERATURE_UNITS: Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
  • TRIGGER_COUPLING: Specifies how the digitizer couples the trigger source.
  • TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES: Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
  • TRIGGER_MAGNITUDE_SLOPE: Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.
  • TRIGGER_SLOPE: Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.
  • TRIGGER_SOURCE_OPERATOR: Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute.
  • TRIGGER_TYPE: The kind of event that triggers the digitizer.
  • VERTICAL_COUPLING: Specifies how the digitizer couples the input signal for the channel.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Int64

Sets an Int64 attribute from the instrument driver. The following attributes are supported:

  • MAX_FIRST_VALID_POINT_VAL
  • NUM_RECORDS_TO_ACQUIRE
  • RECORD_SIZE

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • MAX_FIRST_VALID_POINT_VAL: Returns the maximum value that the First Valid Point parameter of the readout VIs may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.
  • NUM_RECORDS_TO_ACQUIRE: Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
  • RECORD_SIZE: Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi Real64

Sets a Real64 attribute from the instrument driver. The following attributes are supported:

  • INPUT_FILTER_MAX_FREQUENCY
  • INPUT_FILTER_MIN_FREQUENCY
  • INPUT_IMPEDANCE
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY
  • SAMPLE_RATE
  • TRIGGER_DELAY
  • TRIGGER_HYSTERESIS
  • TRIGGER_LEVEL
  • TRIGGER_OUTPUT_OFFSET
  • VERTICAL_OFFSET
  • VERTICAL_RANGE

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • INPUT_FILTER_MAX_FREQUENCY: Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_FILTER_MIN_FREQUENCY: Specifies the minimum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
  • INPUT_IMPEDANCE: The input impedance of this channel. The units are Ohms.
  • REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
  • SAMPLE_CLOCK_EXTERNAL_DIVIDER: Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
  • SAMPLE_CLOCK_EXTERNAL_FREQUENCY: Specifies the frequency of the external signal which is as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
  • SAMPLE_RATE: Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
  • TRIGGER_DELAY: Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
  • TRIGGER_HYSTERESIS: Specifies the trigger hysteresis in Volts.
  • TRIGGER_LEVEL: Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
  • TRIGGER_OUTPUT_OFFSET: Specifies the offset in Volts at the trigger output of the digitizer.
  • VERTICAL_OFFSET: The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
  • VERTICAL_RANGE: The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Set Attribute Vi String

Sets a String attribute from the instrument driver. The following attributes are supported:

  • ACTIVE_TRIGGER_SOURCE
  • CONTROL_IO_SIGNAL
  • TIME_INTERLEAVED_CHANNEL_LIST
  • TRIGGER_OUTPUT_SOURCE

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

Selects which attribute will be accessed. The following attributes are supported :

  • ACTIVE_TRIGGER_SOURCE: Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability.

  • CONTROL_IO_SIGNAL: Signal present on a Control IO connector.

  • TIME_INTERLEAVED_CHANNEL_LIST: Use to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one or more channel names.

  • TRIGGER_OUTPUT_SOURCE: Select the trigger signal to drive the trigger output connector on the front panel.

AttributeValue

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Configuration \ Low Level VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Configuration \ Low Level VIs

Reference Oscillator

Contained in this section are VIs which are used to configure the reference oscillator.

Configure Reference Oscillator Output Enabled

Configure Reference Oscillator


AgMD2 : Configure Reference Oscillator Output Enabled

Configures whether or not the reference frequency signal appears at an output of the digitizer.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Output Enabled (Off)

Specifies whether or not the reference frequency signal appears at a reference output of the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Reference Oscillator

Configures the digitizer's reference oscillator.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Oscillator Source (Reference Oscillator Source Internal)

Specifies the source of the reference frequency signal.

Oscillator Frequency

Specifies the frequency of the external reference oscillator. This parameter is only used if the Source is set to External.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Configuration \ Low Level VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Configuration \ Low Level VIs

Trigger

Contained in this section are VIs related to triggers.

Configure Edge Trigger Source

Configure Pretrigger Samples

Configure Trigger Holdoff

Trigger Magnitude Configure


AgMD2 : Configure Edge Trigger Source

Sets the edge triggering properties. An edge trigger occurs when the trigger signal that you specify with the Source parameter passes through the voltage threshold that you specify with the level parameter and has the slope that you specify with the Slope parameter. This VI affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this VI. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this VI.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Source

Specifies the trigger source. The supported values are:

Name | Description
Channel<n> | Triggers from the channel specified, where <n> is a valid channel number.
External<n> | Triggers from external trigger input specified, where <n> is a valid external trigger input number.
PXI_STAR | Triggers from the PXI Bus Star Trigger.

Trigger Level

Specifies the trigger level.

Trigger Slope (Negative)

Specifies the trigger slope. The supported values are:

Name | Description
Negative | A negative (falling) edge passing through the trigger level triggers the digitizer.
Positive | A positive (rising) edge passing through the trigger level triggers the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Pretrigger Samples

Specifies the number of samples that must be collected before a trigger event will be recognized.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Pretrigger Samples

The number of samples that must be collected before a trigger event will be recognized.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Trigger Holdoff

Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Holdoff

The number of seconds the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Trigger Magnitude Configure

Sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and trigger Type = Magnitude before calling this VI. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this VI.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

TriggerSource

The physical or virtual repeated capability identifier. Pass an empty string if the operation does not apply to a repeated capability. You can also pass an empty string if the device only has a single trigger source.

Level

Specifies the trigger level in Volts.

Hysteresis

Specifies the trigger hysteresis in Volts.

Slope (Trigger Slope Negative)

Specifies whether a rising (Positive) or a falling (Negative) edge triggers the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Acquisition Record

Configures the most commonly configured properties of the digitizer acquisition subsystem. These properties are samples per record, number of records, and sample rate.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

NumRecordsToAcquire

Specifies the number of records in the acquisition.

RecordSize

Specifies the number of samples in each record.

SampleRate

Specifies the sample rate in samples per second.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Channel

Configures the most commonly configured properties of the digitizer channel subsystem. These properties are range, offset, coupling, probe attenuation, and whether the channel is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Enabled (Off)

Specifies if the channel is enabled for acquisition.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Vertical Range

Specifies the vertical range.

Vertical Offset

Specifies the vertical offset.

Vertical Coupling (AC)

Specifies how to couple the input signal. The supported values are:

Name | Description
AC | The digitizer AC couples the input signal.
DC | The digitizer DC couples the input signal.
GND | The digitizer couples the channel to the ground.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Input Filter

Configures the minimum and maximum input filter frequencies for a specified channel.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Min Frequency

Specifies the minimum input filter frequency.

Max Frequency

Specifies the maximum input filter frequency.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Temperature Units

Configures the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Temperature Units (Temperature Units Celsius)

Temperature units to be used by the Board Temperature and Channel Temperature attributes. Supported values are:

Name | Description
Celsius | Temperature values returned from the digitizer are in degrees Celsius.
Fahrenheit | Temperature values returned from the digitizer are in degrees Fahrenheit.
Kelvin | Temperature values returned from the digitizer are in degrees Kelvin.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Configure Time Interleaved Channel List

Combines this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Channel List

A comma-separated list of one or more channel names to combine with the channel specified by Channel Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Module Synchronization Configure Slaves

Configures the modules which are identified by their handles, as synchronized slaves of the current module (which becomes a master module).

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

SlavesCount

Number of Slaves in the array.

Slaves

Array of slaves.

Numeric

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Data VIs

Contained in this section are VIs which are used to collect data from the instrument.

Fetch

Fetch Waveform Int16

Fetch Waveform Int32

Fetch Waveform Int8

Fetch Waveform Real64

Fetch Multi-Record

Fetch Multi-Record Waveform Int16

Fetch Multi-Record Waveform Int32

Fetch Multi-Record Waveform Int8

Fetch Multi-Record Waveform Real64

Read

Read Waveform Int16

Read Waveform Int32

Read Waveform Int8

Read Waveform Real64

Module Synchronization Get Slaves


Data \ Low Level VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Data \ Low Level VIs

Fetch VIs

Contained in this section are VIs which are used to access the low-level operations of the instrument.

Fetch Waveform Int16

Fetch Waveform Int32

Fetch Waveform Int8

Fetch Waveform Real64


AgMD2 : Fetch Waveform Int16

Returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Waveform Array Size

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Waveform Int32

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Waveform Array Size

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Waveform Int8

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Waveform Array Size

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Waveform Real64

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Waveform Array Size

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Data \ Low Level VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Data \ Low Level VIs

Fetch Multi-Record VIs

Contained in this section are VIs which are used to access the low-level operations of the instrument.

Fetch Multi-Record Waveform Int16

Fetch Multi-Record Waveform Int32

Fetch Multi-Record Waveform Int8

Fetch Multi-Record Waveform Real64


AgMD2 : Fetch Multi-Record Waveform Int16

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Int32

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Int8

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition.Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Fetch Multi-Record Waveform Real64

Returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

ChannelName

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

WaveformArray

Buffer into which the acquired waveform is stored.

Numeric

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Data \ Low Level VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Data \ Low Level VIs

Read VIs

Contained in this section are VIs which are used to access the low-level operations of the instrument.

Read Waveform Int16

Read Waveform Int32

Read Waveform Int8

Read Waveform Real64


AgMD2 : Read Waveform Int16

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Maximum Time

Specifies the maximum time the end-user allows for this method to complete in milliseconds. Use '0' for immediate (no wait), and '-1' to wait indefinitely.

Waveform Array Size

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Read Waveform Int32

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Maximum Time

Specifies the maximum time the end-user allows for this method to complete in milliseconds. Use '0' for immediate (no wait), and '-1' to wait indefinitely.

Waveform Array Size

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Read Waveform Int8

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data + ScaleOffset.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Maximum Time

Specifies the maximum time the end-user allows for this method to complete in milliseconds. Use '0' for immediate (no wait), and '-1' to wait indefinitely.

Waveform Array Size

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Read Waveform Real64

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. Pass an empty string if operation does not apply to a repeated capability.

Maximum Time

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

Waveform Array Size

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Module Synchronization Get Slaves

Retrieves the handles of the Slave modules which are synchronized with the current master. If the current module is a synchronized slave, or is not a synchronized module, then no slaves will be returned.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

SlavesBufferSize

Number of elements in Slaves.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Slaves

Array of Slaves.

Numeric

ActualSlaves

Actual number of elements in Slaves.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Utility VIs

Contained in this section are VIs which are used to control various functions of the instrument.

Calibration

Calibration Cancel

Calibration Load From File

Calibration Save To File

Instrument Info

Instrument Info Attribute ID Value From String

Instrument Info Attribute ID Value To String

Disable

Error Message

Error-Query

Query Board Temperature

Query Channel Temperature

Query Min Waveform Memory

Reset

Reset With Defaults

Revision Query

Self Calibrate

Self-Test


Utility VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Utility VIs

Calibration VIs

Contained in this section are calibration-related VIs.

Calibration Cancel

Calibration Load From File

Calibration Save To File


AgMD2 : Calibration Cancel

Aborts any running self-calibration and returns.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Calibration Load From File

Loads calibration values and info from file.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Path

Path of the file from where the information will be loaded.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Calibration Save To File

Saves calibration values and information in a binary file.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Path

Path of the binary file to which the information will be saved.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Utility VIs

You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Methods (VIs) > Utility VIs

Instrument Info

Contained in this section are VI's which are used to control various functions of the instrument.

Instrument Info Attribute ID Value From String

Instrument Info Attribute ID Value To String


AgMD2 : Instrument Info Attribute ID Value From String

Converts the string representation of a property ID to its numeric value.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Str

String representation of the property ID, without the prefix 'PREFIX_ATTR_'.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Value

Numeric value of the property ID.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Instrument Info Attribute ID Value To String

Converts a property ID into its string representation.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Value

Property ID value.

StrBufferSize

Number of elements in Name.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Str

String representation of the property ID , without the prefix 'PREFIX_ATTR_'.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Disable

-- NOT SUPPORTED -- Quickly places the instrument in a state where it has no or minimal effect on the external system to which it is connected. This state is not necessarily a known state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Error Message

Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Error Code

Instrument driver status code.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Error Message

Instrument driver error message.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Error Query

Queries the instrument and returns instrument specific error information. This VI can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error code

Instrument error code.

error message

Instrument error message.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Query Board Temperature

Query the temperature of the entire board. The units are governed by the Temperature Units attribute.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Board Temperature

Returns the current temperature of the entire board. The units are governed by the Temperature Units attribute.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Query Channel Temperature

Queries the temperature of a specific channel. The units are governed by the Temperature Units attribute.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The name of the channel.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Board Temperature

Returns the current temperature of the specified channel. The units are governed by the Temperature Units attribute.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Query Min Waveform Memory

Determines the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Data Width

Specifies the size of the sampled data that will be retrieved. The value of this parameter must be 8, 16, 32 or 64, corresponding to the intended Read/Fetch function.

Number of Records

Specifies the number of records that will be read.

Offset Within Record

Specifies the start index within the record from which the data should be retrieved.

Number of Points Per Record

Specifies the number of data points to return.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Number of Samples

The minimum buffer size in samples needed for a subsequent Read or Fetch call with the same readout parameters.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Reset

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers).

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Reset With Defaults

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Revision Query

Retrieves revision information from the instrument.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

instrument driver revision

Returns the revision of the IVI specific driver.

firmware revision

Returns the firmware revision of the instrument.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Self Calibrate

Executes all internal calibrations. If the digitizer does not support calibration, this VI silently succeeds. This operation can take 1-2 minutes to complete.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Self Test

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'. This operation can take 1-2 minutes to complete.

This function actually performs an identical operation to the Self-Calibrate, but with the addition of an output message.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

self test result

The numeric result from the self test operation. 0 = no error (test passed)

self-test message

The self test status message.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 Attributes

This section provides technical and programming support for using the Agilent AgMD2 LabVIEW API VIs to develop applications for your Digitizers.

The Attributes are values used by certain of the Vis to configure and return data about the state of the instrument.

ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED

ACQUISITION_MODE

ACTIVE_TRIGGER_SOURCE

BOARD_TEMPERATURE

CALIBRATION_IS_REQUIRED

CHANNEL_CONNECTOR_NAME

CHANNEL_COUNT

CHANNEL_ENABLED

CHANNEL_TEMPERATURE

CONTROL_IO_AVAILABLE_SIGNALS

CONTROL_IO_COUNT

CONTROL_IO_SIGNAL

DELAY_CONTROL_COUNT

DELAY_CONTROL_ENABLE

DELAY_CONTROL_MAX

DELAY_CONTROL_MIN

DELAY_CONTROL_RANGE

DELAY_CONTROL_VALUE

DRIVER_SETUP

INPUT_CONNECTOR_SELECTION

INPUT_FILTER_BYPASS

INPUT_FILTER_MAX_FREQUENCY

INPUT_FILTER_MIN_FREQUENCY

INPUT_IMPEDANCE

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_INFO_CHASSIS_NUMBER

INSTRUMENT_INFO_IO_VERSION

INSTRUMENT_INFO_NBRADC_BITS

INSTRUMENT_INFO_OPTIONS

INSTRUMENT_INFO_SERIAL_NUMBER_STRING

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_RESOURCE_DESCRIPTOR

IS_IDLE

IS_MEASURING

IS_WAITING_FOR_ARM

IS_WAITING_FOR_TRIGGER

LOGIC_DEVICE_COUNT

LOGIC_DEVICE_FIRMWARE_STORE_COUNT

LOGIC_DEVICE_IFDL_COUNT

LOGIC_DEVICE_IFDL_ENABLED

LOGIC_DEVICE_IFDL_IS_ACTIVE

LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL

LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE

LOGIC_DEVICE_MEMORY_BANK_COUNT

LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED

LOGIC_DEVICE_SAMPLES_UNSIGNED

LOGIC_DEVICE_STREAM_MODE

LOGIC_DEVICE_STREAMS_COUNT

LOGICAL_NAME

MAX_FIRST_VALID_POINT_VAL

MAX_SAMPLES_PER_CHANNEL

MIN_RECORD_SIZE

MODULE_SYNCHRONIZATION_HANDLE

MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE

MONITORING_VALUE_COUNT

MONITORING_VALUE_CURRENT_VALUE

MONITORING_VALUE_LIMIT_HIGH

MONITORING_VALUE_LIMIT_LOW

MONITORING_VALUE_UNIT

NUM_ACQUIRED_RECORDS

NUM_RECORDS_TO_ACQUIRE

RECORD_SIZE

REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

REFERENCE_OSCILLATOR_OUTPUT_ENABLED

REFERENCE_OSCILLATOR_SOURCE

SAMPLE_CLOCK_EXTERNAL_DIVIDER

SAMPLE_CLOCK_EXTERNAL_FREQUENCY

SAMPLE_CLOCK_OUTPUT_ENABLED

SAMPLE_CLOCK_SOURCE

SAMPLE_RATE

SIMULATE

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

SUPPORTED_INSTRUMENT_MODELS

TEMPERATURE_UNITS

TIME_INTERLEAVED_CHANNEL_LIST

TIME_INTERLEAVED_CHANNEL_LIST_AUTO

TRIGGER_COUPLING

TRIGGER_DELAY

TRIGGER_HYSTERESIS

TRIGGER_LEVEL

TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES

TRIGGER_MAGNITUDE_SLOPE

TRIGGER_OUTPUT_ENABLED

TRIGGER_OUTPUT_OFFSET

TRIGGER_OUTPUT_SOURCE

TRIGGER_SLOPE

TRIGGER_SOURCE_COUNT

TRIGGER_SOURCE_OPERATOR

TRIGGER_TYPE

USER_CONTROL_COUNTERS_MODE

USER_CONTROL_INTER_SEGMENT_DELAY_MODE

USER_CONTROL_INTER_SEGMENT_DELAY_VALUE

USER_CONTROL_POST_TRIGGER

USER_CONTROL_PRE_TRIGGER

USER_CONTROL_START_ON_TRIGGER_ENABLED

USER_CONTROL_TRIGGER_ENABLE_SOURCE

USER_CONTROL_TRIGGER_FACTOR

USER_CONTROL_TRIGGER_SELECTION

VERTICAL_COUPLING

VERTICAL_OFFSET

VERTICAL_RANGE


ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED

Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.

Data Type

Boolean
Supported Values

True

False


ACQUISITION_MODE

The acquisition mode, Normal digitizer or digital Downconverter.

Data Type

Integer32
Supported Values
0x00000000 | Normal | Normal digitizer mode
0x0000000C | Downconverter | Digital Downconverter mode
Notes

Downconverter mode requires model: M9202A


ACTIVE_TRIGGER_SOURCE

Specifies the source the digitizer monitors for the trigger event.

Data Type

String
Supported Values
'Channel<n>' | where <n> = a valid channel number
'External<n>' | where <n> = a valid channel number
'PXI_STAR' | Triggers from the PXI star trigger
Notes

The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability


BOARD_TEMPERATURE

Indicates the temperature of the entire board.

Data Type

Real64, Read-Only
Notes

The units are governed by the Temperature Units attribute.


CALIBRATION_IS_REQUIRED

Returns whether or not a self calibration is required.

Data Type

Boolean
Supported Values
True | Self calibration is required.
False | Self calibration is not required.


CHANNEL_CONNECTOR_NAME

The connector name as it appears on the instrument's front panel.

Data Type

String, Read-Only


CHANNEL_COUNT

The number of channels present on the instrument.

Data Type

Unsigned Integer32, Read-Only


CHANNEL_ENABLED

Specifies whether the digitizer acquires a waveform for the channel.

Data Type

Boolean
Supported Values
True | A waveform is acquired for the selected channel.
False | A waveform is not acquired for the selected channel.


CHANNEL_TEMPERATURE

Indicates the temperature of the channel.

Data Type

Real64, Read-Only
Notes

The units are governed by the Temperature Units attribute.


CONTROL_IO_AVAILABLE_SIGNALS

Comma separated list of available signal names that can be used for the Signal attribute of this repeated capability.

Data Type

String, Read-Only


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > CONTROL_IO_COUNT

CONTROL_IO_COUNT

Returns the number of Control IO Connectors.

Data Type

Integer32, Read-Only


CONTROL_IO_SIGNAL

Signal present on a Control IO connector.

Data Type

String, Read-Only
Notes

Setting of a signal value does not immediately apply the change to the instrument. In order for the change to be effective, ApplySetup must be called.

This behavior is consistent for all settings changes. Note that some actions do perform an implicit ApplySetup. Please refer to the documentation of this method for details.


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > DELAY_CONTROL_COUNT

DELAY_CONTROL_COUNT

Returns the number of delay controls available.

Data Type

Integer32, Read-Only


DELAY_CONTROL_ENABLE

Specifies whether the delay controls are set manually

Data Type

Boolean
Supported Values
True | All delay controls must be set manually.
False | The delay controls are set by the self-calibration.


DELAY_CONTROL_MAX

Maximum value (DAC code) that can be set for the delay control.

Data Type

Integer32, Read-Only


DELAY_CONTROL_MIN

Minimum value (DAC code) that can be set for the delay control.

Data Type

Integer32, Read-Only


DELAY_CONTROL_RANGE

Selects the range for the delay control. Useful only for delay controls with multiple ranges.

Data Type

Integer32, Read-Only


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > DELAY_CONTROL_VALUE

DELAY_CONTROL_VALUE

The value (DAC code) set for the delay control.

Data Type

Integer32


DRIVER_SETUP

The driver setup string.

It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize With Options VI.

Data Type

String, Read-Only
Notes

Driver setup is empty if the driver is not initialized.


INPUT_CONNECTOR_SELECTION

Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, then the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.

Data Type

Unsigned Integer32
Supported Values
0x00000001 | Connector 1 is used
0x00000002 | Connector 2 is used


INPUT_FILTER_BYPASS

Specifies whether or not to bypass the input filter.

Data Type

Boolean
Supported Values
True | The input filter is bypassed
False | The input filter is used.


INPUT_FILTER_MAX_FREQUENCY

Specifies the maximum input filter frequency.

The units are Hertz.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Notes

Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed.


INPUT_FILTER_MIN_FREQUENCY

Specifies the minimum input filter frequency.

The units are Hertz.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Notes

Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed.


INPUT_IMPEDANCE

The input impedance of the channel. The units are Ohms.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, refer to the specific instrument user guide for information.


INSTRUMENT_FIRMWARE_REVISION

The firmware revision reported by the physical instrument.

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > INSTRUMENT_INFO_CHASSIS_NUMBER

INSTRUMENT_INFO_CHASSIS_NUMBER

Chassis number.

Data Type

Unsigned Integer32, Read-Only


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > INSTRUMENT_INFO_IO_VERSION

INSTRUMENT_INFO_IO_VERSION

Version of the IO Driver used by this module.

Data Type

String, Read-Only


INSTRUMENT_INFO_NBRADC_BITS

Number of bits of data per sample from this module's ADCs.

Data Type

Unsigned Integer32, Read-Only


INSTRUMENT_INFO_OPTIONS

List of comma separated options installed in this instrument.

Data Type

String, Read-Only


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > INSTRUMENT_INFO_SERIAL_NUMBER_STRING

INSTRUMENT_INFO_SERIAL_NUMBER_STRING

The serial number string of the instrument. Read only

Data Type

String Read-Only


INSTRUMENT_MANUFACTURER

The name of the manufacturer reported by the physical instrument.

Manufacturer is limited to 256 bytes

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition.


INSTRUMENT_MODEL

The model number or name reported by the physical instrument.

Model is limited to 256 bytes

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition.


IO_RESOURCE_DESCRIPTOR

The resource descriptor specifies the connection to a physical device.

It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function.

Data Type

String, Read-Only
Notes

It is empty if the driver is not initialized.


IS_IDLE

Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Unsigned Integer32, Read-Only
Supported Values
0x00000001 | Instrument is in the Idle state
0x00000002 | Instrument in not in the Idle state
0x00000003 | The state of the instrument is unknown


IS_MEASURING

Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Unsigned Integer32, Read-Only
Supported Values
0x00000001 | The instrument is currently in the Measuring state
0x00000002 | The instrument is not in the Measuring state
0x00000003 | The driver cannot query the instrument to determine if the digitizer is in the Measuring state.


IS_WAITING_FOR_ARM

Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Unsigned Integer32, Read-Only
Supported Values
0x00000001 | The instrument is currently Waiting for Arm
0x00000002 | The instrument is not Waiting for Arm
0x00000003 | The driver cannot query the instrument to determine if the digitizer is Waiting for Arm.


IS_WAITING_FOR_TRIGGER

Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Unsigned Integer32, Read-Only
Supported Values
0x00000001 | The instrument is currently waiting for a trigger event
0x00000002 | The instrument is not waiting for a trigger
0x00000003 | The driver cannot query the instrument to determine if the digitizer is Waiting for trigger event


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > LOGIC_DEVICE_COUNT

LOGIC_DEVICE_COUNT

Returns the number of logic devices.

Data Type

Integer32, Read-Only


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > LOGIC_DEVICE_FIRMWARE_STORE_COUNT

LOGIC_DEVICE_FIRMWARE_STORE_COUNT

Number of available firmware stores in the LogicDevice.

Data Type

Integer32, Read-Only


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > LOGIC_DEVICE_IFDL_COUNT

LOGIC_DEVICE_IFDL_COUNT

Returns the number of LogicDevice IFDLs.

Data Type

Integer32, Read-Only


LOGIC_DEVICE_IFDL_ENABLED

Specifies whether the IFDL is enabled.

Data Type

Boolean
Supported Values
True | The IFDL is enabled.
False | The IFDL is not enabled.


LOGIC_DEVICE_IFDL_IS_ACTIVE

Returns whether the IFDL is currently active.

Data Type

Boolean
Supported Values
True | The IFDL is active.
False | The IFDL is not active.


LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL

Specifies how the MemoryBank accesses are controlled. This value is used only when the Acquisition Mode is UserFDK.

Data Type

Integer32, Read-Only
Supported Values
AGMD2_VAL_LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL_SOFTWARE | Software control of LogicDevice MemoryBank. In this mode, the value of LogicDevice Memory Access Mode indicates whether the memory is used for reading or writing.
AGMD2_VAL_LOGIC_DEVICE_MEMORY_BANK_ACCESS_CONTROL_USER_FIRMWARE | Custom control of LogicDevice MemoryBank from the User Firmware. In this mode, the User Firmware controls accesses to the memory, and the value of LogicDevice Memory Acces Mode is ignored.


LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE

When MemoryBank access is controlled by software, specifies how the memory is currently accessed.

Data Type

Integer32, Read-Only
Supported Values
AGMD2_VAL_LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE_WRITE | Under Software LogicDevice MemoryBank Access Control, this value indicates that the memory is currently used for Writing.
AGMD2_VAL_LOGIC_DEVICE_MEMORY_BANK_ACCESS_MODE_READ | Under Software LogicDevice MemoryBank Access Control, this value indicates that the memory is currently used for Reading.


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > LOGIC_DEVICE_MEMORY_BANK_COUNT

LOGIC_DEVICE_MEMORY_BANK_COUNT

Number of memory banks in LogicDevice.

Data Type

Integer32, Read-Only


LOGIC_DEVICE_MEMORY_BANK_FIFO_MODE_ENABLED

Enables the FIFO mode for MemoryBank. Used when streaming.

Data Type

Boolean
Supported Values
True | TheFIFO mode is enabled for MemoryBank.
False | The FIFO mode is not enabled for MemoryBank.


LOGIC_DEVICE_SAMPLES_UNSIGNED

When True, directs the LogicDevice to receive unsigned samples values from the ADC.

Data Type

Boolean
Supported Values
True | Directs the LogicDevice to receive unsigned samples values from the ADC.
False | Does not direct the LogicDevice to receive unsigned samples values from the ADC.


LOGIC_DEVICE_STREAM_MODE

Specifies the mode the Streams are operating in.

Data Type

Integer32, Read-Only
Supported Values
AGMD2_VAL_LOGIC_DEVICE_STREAM_MODE_ACQUISITION | In Acquisition mode, the LogicDevice receives actual values from the ADC. This is the default mode.
AGMD2_VAL_LOGIC_DEVICE_STREAM_MODE_EMULATION | In Emulation mode, the LogicDevice receives the values that have been uploaded to each stream using WriteStreamWaveformInt16().


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > LOGIC_DEVICE_STREAMS_COUNT

LOGIC_DEVICE_STREAMS_COUNT

Number of Streams available in the LogicDevice.

Data Type

Integer32, Read-Only


LOGICAL_NAME

Logical Name identifies a driver session in the Configuration Store.

Data Type

String, Read-Only
Notes

If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.


MAX_FIRST_VALID_POINT_VAL

Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieve the entire acquisition.

Data Type

Integer64


MAX_SAMPLES_PER_CHANNEL

Returns the maximum number of samples per channel that can be captured.

Data Type

Integer64, Read-Only


MIN_RECORD_SIZE

Indicates the minimum waveform record size.

Data Type

Integer64, Read-Only
Notes

If the digitizer can support any arbitrary size record, then this attribute returns 1.


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > MODULE_SYNCHRONIZATION_HANDLE

MODULE_SYNCHRONIZATION_HANDLE

The handle of the current module.

Data Type

Integer32, Read-Only


MODULE_SYNCHRONIZATION_MASTER_MODULE_HANDLE

The handle of the master module, when synchronized. This value will be identical to the attribute Handle if this module is the master, and equal to 0 when not synchronized.

Data Type

Integer32, Read-Only


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > MONITORING_VALUE_COUNT

MONITORING_VALUE_COUNT

Returns the number of MonitoringValues.

Data Type

Integer32, Read-Only


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > MONITORING_VALUE_CURRENT_VALUE

MONITORING_VALUE_CURRENT_VALUE

Returns the current monitored value of the MonitoringValue.

Data Type

Real64


MONITORING_VALUE_LIMIT_HIGH

Returns the limit value above which the instrument behavior may not be consistent with the specifications.

Data Type

Real64


MONITORING_VALUE_LIMIT_LOW

Returns the limit value below which the instrument behavior may not be consistent with the specifications.

Data Type

Real64


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > MONITORING_VALUE_UNIT

MONITORING_VALUE_UNIT

Returns the unit of this monitoring value.

Data Type

String, Read-Only


NUM_ACQUIRED_RECORDS

Gets the total number of records acquired since the acquisition was last initiated.

Data Type

Integer64, Read-Only
Notes

You may check this value while an acquisition is in progress.


NUM_RECORDS_TO_ACQUIRE

Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.

Data Type

Integer64


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > RECORD_SIZE

RECORD_SIZE

Specifies the number of samples to acquire in each waveform record.

Data Type

Integer64


REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

Specifies the frequency of the external signal which is used as a frequency reference.

The units are Hertz.

Data Type

Real64
Notes

This value is used only if the Reference Oscillator Source attribute is set to External.


REFERENCE_OSCILLATOR_OUTPUT_ENABLED

Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.

Data Type

Boolean
Supported Values
True | The reference oscillator output signal is enabled.
False | The reference oscillator output is disabled.


REFERENCE_OSCILLATOR_SOURCE

Specifies the reference frequency source used.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | The internal reference oscillator is used.
0x00000001 | An external reference oscillator is used.
0x00000002 | PXI 10 MHz reference clock is used.
0x00000003 | PXIe 100 MHz reference clock is used.
0x00000004 | AXIe 100 MHz reference clock is used.

The validity of these values is model dependant, please check the capability of your particular model.


SAMPLE_CLOCK_EXTERNAL_DIVIDER

Specifies the value by which the external sample clock should be divided.

Data Type

Real64
Notes

This value is used only if the Sample Clock Source attribute is set to External.


SAMPLE_CLOCK_EXTERNAL_FREQUENCY

Specifies the frequency of the external signal which is used as a sample clock.

The units are Hertz.

Data Type

Real64
Notes

This value is used only if the Sample Clock Source attribute is set to External.


SAMPLE_CLOCK_OUTPUT_ENABLED

Specifies whether or not the sample clock appears at a reference output of the digitizer.

Data Type

Boolean
Supported Values
True | The sample clock appears at a reference output of the digitizer.
False | The sample clock does not appear at a reference output of the digitizer.


SAMPLE_CLOCK_SOURCE

Specifies the clock used to pace acquisition sampling.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | The internal sample clock is used.
0x00000001 | An external sample clock is used.


SAMPLE_RATE

Specifies the rate of the sample clock in samples per second.

This number represents the inverse of the interval between samples in the acquisition record. i.e Sample/s = 1/f

Data Type

Real64


SIMULATE

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

Data Type

Boolean
Supported Values
True | The instrument simulates values for output parameters.
False | The instrument operates normally.


SPECIFIC_DRIVER_DESCRIPTION

Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


SPECIFIC_DRIVER_REVISION

Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


SPECIFIC_DRIVER_VENDOR

Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


SUPPORTED_INSTRUMENT_MODELS

A comma-separated list of instrument models that the IVI specific driver can control.

Data Type

String, Read-Only
Notes

The string does not include an abbreviation for the manufacturer if it is the same for all models.


TEMPERATURE_UNITS

Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | Temperature values returned from the digitizer are in degrees Celsius.
0x00000001 | Temperature values returned from the digitizer are in degrees Fahrenheit.
0x00000002 | Temperature values returned from the digitizer are in degrees Kelvin.


TIME_INTERLEAVED_CHANNEL_LIST

This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.

Data Type

String


TIME_INTERLEAVED_CHANNEL_LIST_AUTO

Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates.

Data Type

Boolean
Supported Values
True | The instrument automatically combines channels to meet the sample rate requirements specified via the Sample Rate attribute.
False | The instrument does not automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.


TRIGGER_COUPLING

Specifies how the digitizer couples the trigger source.

Data Type

Integer32
Supported Values
0x00000000 | AC | The digitizer AC couples the trigger signal.
0x00000001 | DC | The digitizer DC couples the trigger signal.
0x00000002 | HF Reject | The digitizer filters out the high frequencies from the trigger signal.


TRIGGER_DELAY

Specifies the length of time from the trigger event to the first point in the waveform record.

The units are seconds.

Data Type

Real64
Supported Values
negative | Pre-Trigger | If the value is negative, the first point in the waveform record occurs before the trigger event.
positive | Post-Trigger | If the value is positive, the first point in the waveform record occurs after the trigger event


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > TRIGGER_HYSTERESIS

TRIGGER_HYSTERESIS

Specifies the trigger hysteresis in Volts.

Data Type

Real64


TRIGGER_LEVEL

Specifies the voltage threshold for the trigger sub-system.

The units are Volts.

Data Type

Real64
Notes

This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger.

This attribute, along with the Trigger Slope, Active Trigger Source, and Trigger Coupling attributes, define the trigger event when the Trigger Type is set to Edge Trigger.


TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES

Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.

Data Type

Integer32


TRIGGER_MAGNITUDE_SLOPE

Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.

Data Type

Integer32
Supported Values
AGMD1_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level, triggers the digitizer.
AGMD1_VAL_POSITIVE | A positive (rising) edge passing through the trigger level, triggers the digitizer.
Notes

Requires model: M9202A


TRIGGER_OUTPUT_ENABLED

Specifies whether or not an accepted trigger appears at an output of the digitizer.

Data Type

Boolean
Supported Values
True | The trigger appears at the output of the digitizer.
False | The trigger output is disabled.


TRIGGER_OUTPUT_OFFSET

Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range).

Units are Volts.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, refer to the specific instrument user guide for information.


TRIGGER_OUTPUT_SOURCE

Selects the trigger source to drive the TRG OUT output connector on the front panel.

Possible values are "Channel1" to "Channel<n>" or "External1" to "External<n>" trigger sources.

Data Type

String
Supported Values
Channel<1..n> | Specifies channel<n> | Where <n> is the number of available channels.
External<1..n> | Specifies external trigger <n> | Where <n> is the number of available external trigger inputs.
TriggerCompare | Trigger source conditions have been met. (Not necessarily triggered) | (M97xxA only)
TriggerAccepted | Trigger source conditions have been met & trigger was enabled - Trigger has occurred. | (M97xxA only)
AXIe_TRIG<0..11> | One of 12 AXIe bus trigger lines (output). | (M97xxA only)
AXIe_STRIG | The AXIe star trigger | (M97xxA only)
HighLevel | Output is held high (for test purposes) | (M97xxA only)
LowLevel | Output is held low (for test purposes) | (M97xxA only)


TRIGGER_SLOPE

Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | Negative | A negative (falling) edge passing through the trigger level triggers the digitizer.
0x00000001 | Positive | A positive (rising) edge passing through the trigger level triggers the digitizer.


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > TRIGGER_SOURCE_COUNT

TRIGGER_SOURCE_COUNT

The number of trigger sources present on the instrument.

Data Type

Integer32, Read-Only


TRIGGER_SOURCE_OPERATOR

Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute. See the definition of that attribute for details.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | AND | Trigger sources are logically AND'd together. The digitizer triggers when all configured trigger source conditions are satisfied.
0x00000001 | OR | Trigger sources are logically OR'd together. The digitizer triggers when the first configured trigger source condition is satisfied.
0x00000002 | None | No operator is applied to the configured list of trigger sources. The trigger source list is ignored, and the digitizer triggers when the currently configured trigger source, given by the Active Trigger Source attribute, and its associated trigger conditions are satisfied.


TRIGGER_TYPE

The kind of event that triggers the digitizer.

Data Type

Unsigned Integer32
Supported Values
0x00000001 | Edge Trigger | Configures the digitizer for edge triggering. An edge trigger occurs when the trigger signal specified with the Active Trigger Source attribute passes the voltage threshold specified with the Trigger Level attribute and has the slope specified with the Trigger Slope attribute.
0x00000005 | TV Trigger | Configures the digitizer for triggering on TV signals.
0x000003E9 | Immediate Trigger | Immediately triggers the measurement.
0x000003EA | Magnitude Trigger | Magnitude triggering. Only valid when Acquisition Mode = Downconverter. Requires model: M9202A
Notes

TV triggering requires External trigger source.


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > USER_CONTROL_COUNTERS_MODE

USER_CONTROL_COUNTERS_MODE

Specifies the Counters Mode.

Data Type

Integer32


USER_CONTROL_INTER_SEGMENT_DELAY_MODE

Specifies how the Inter Segment Delay is managed. In Software mode, the Inter Segment Delay is given as a fixed number of blocks, in the Inter Segment Delay Value attribute. In Firmware mode, the Inter Segment Delay is controlled directly by the User Firmware.

Data Type

Integer32


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > USER_CONTROL_INTER_SEGMENT_DELAY_VALUE

USER_CONTROL_INTER_SEGMENT_DELAY_VALUE

Number of Inter Segments Delay blocks.

Data Type

Integer32


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > USER_CONTROL_POST_TRIGGER

USER_CONTROL_POST_TRIGGER

Number of Post-Trigger blocks.

Data Type

Integer32


You are here: AgMD2 LabVIEW Driver Help > Programming Reference > AgMD2 Attributes > USER_CONTROL_PRE_TRIGGER

USER_CONTROL_PRE_TRIGGER

Number of Pre-Trigger blocks.

Data Type

Integer32


USER_CONTROL_START_ON_TRIGGER_ENABLED

Specifies whether the segmentation mechanism should work in Start On Trigger mode. While in Start On Trigger mode, the PreTrigger value is ignored.

Data Type

Boolean
Supported Values
True | The segmentation mechanism works in Start On Trigger mode.
False | The segmentation mechanism does not work in Start On Trigger mode.


USER_CONTROL_TRIGGER_ENABLE_SOURCE

Specifies the Source of the Trigger Enable, either from the Segmentation mechanism, or from the User Firmware.

Data Type

Integer32


USER_CONTROL_TRIGGER_FACTOR

Multiplicative factor for the PreTrigger and PostTrigger values, to be used with sparsing. Default value 1.

Data Type

Integer32


USER_CONTROL_TRIGGER_SELECTION

Specifies the source of the Trigger, either from the analog circuitry, or from the digital user firmware.

Data Type

Integer32


VERTICAL_COUPLING

Specifies how the digitizer couples the input signal for the channel.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | The digitizer AC couples the input signal.
0x00000001 | The digitizer DC couples the input signal.
0x00000002 | The digitizer couples the channel to the ground.


VERTICAL_OFFSET

The location of the center of the range that you specify with the Vertical Range attribute.

The units are Volts, with respect to ground.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Notes

For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.


VERTICAL_RANGE

The absolute value of the input range the digitizer can acquire for the channel.

The units are Volts.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Notes

For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.


AgMD2 : IVI Error Converter

Convert error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

IVI error code (0)

Error code returned from an IVI instrument driver operation.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


AgMD2 : Send Software Arm

--NOT SUPPORTED-- This VI follows semantics similar to Send Software Trigger. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of the Send Software Trigger function.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.


Name

VI description overview text.

Data Type

I/O

Boolean

Integer32

Integer64

String

Real64

Supported Values


AgMD2 : *Name of VI*

*Description*

* [image] *

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... Collapsed The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

status

The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

code

The code input identifies the error or warning.

source

The source string describes the origin of the error or warning.

Image library:

Input icons |
 | I/O in
 | error in
 | boolean in
 | integer 32 in
 | integer 64 in
 | string in
 | double in
 | unsigned int 32 in
Output icons |
 | I/O out
 | error out
 | boolean out
 | integer 8 out
 | integer 16 out
 | integer 32 out
 | integer 64 out
 | string out
 | double out
 | unsigned int 32 out
 | array of integer 8 out
 | array of integer 16 out
 | array of integer 32 out
 | array of integer 64 out
 | array of doubles out


EEPROM_MODULE_GENERATION_OPTIONS

This attribute is private and for Agilent-internal use only.

Data Type

String


EEPROM_MODULE_GENERATION_SERIAL_NUMBER

This attribute is private and for Agilent-internal use only.

Data Type

String


PRIVATE_CALIBRATION_USER_SIGNAL

This attribute is private and for Agilent-internal use only.

Data Type

String


PRIVATE_STORE_BAR_CODE

This attribute is private and for Agilent-internal use only.

Data Type

String


PRIVATE_STORE_COUNT

This attribute is private and for Agilent-internal use only.

Data Type

Integer32, Read-Only


PRIVATE_STORE_PART_NUMBER

This attribute is private and for Agilent-internal use only.

Data Type

String


PRIVATE_STORE_PART_NUMBER_REVISION

This attribute is private and for Agilent-internal use only.

Data Type

String


PRIVATE_STORE_PRODUCTION_DATE

This attribute is private and for Agilent-internal use only.

Data Type

String


PRIVATE_STORE_SERIAL_NUMBER

This attribute is private and for Agilent-internal use only.

Data Type

String


PRIVATE_STORE_TEST_DATE

This attribute is private and for Agilent-internal use only.

Data Type

String